Scientific Linux Security Update : libvorbis on SL5.x, SL4.x, SL3.x i386/x86_64

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote Scientific Linux host is missing one or more security
updates.

Description :

Several flaws were found in the way libvorbis processed audio data. An
attacker could create a carefully crafted OGG audio file in such a way
that it could cause an application linked with libvorbis to crash or
execute arbitrary code when it was opened. (CVE-2007-3106,
CVE-2007-4029, CVE-2007-4065, CVE-2007-4066)

See also :

http://www.nessus.org/u?882c19b6

Solution :

Update the affected libvorbis and / or libvorbis-devel packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: Scientific Linux Local Security Checks

Nessus Plugin ID: 60252 ()

Bugtraq ID:

CVE ID: CVE-2007-3106
CVE-2007-4029
CVE-2007-4065
CVE-2007-4066