Asterisk Multiple Caller Simultaneous Voicemail Account Manipulation Double-free Remote DoS (AST-2012-011)

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The version of Asterisk installed on the remote host may be affected
by a denial of service vulnerability.

Description :

According to the version in its SIP banner, the version of Asterisk
running on the remote host is potentially affected by a vulnerability
that could allow a remote, authenticated attacker to crash the server.

If two remote users interact with a single voicemail account in
unspecified ways, memory can be corrupted by a double-free vulnerability and this
can further lead to application crashes.

See also :

Solution :

Upgrade to Asterisk / 10.5.2, Certified Asterisk 1.8.11-cert4
or apply the patches listed in the Asterisk advisory.

Risk factor :

Medium / CVSS Base Score : 4.0
CVSS Temporal Score : 3.0
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 60065 ()

Bugtraq ID: 54317

CVE ID: CVE-2012-3812