Quagga < 0.99.9 BGPD Multiple Denial of Service Vulnerabilities

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by multiple denial of service
vulnerabilities.

Description :

According to its self-reported version number, the installation of
Quagga's BGP daemon listening on the remote host is affected by
multiple denial of service vulnerabilities :

- A denial of service vulnerability can be triggered by a
malformed OPEN message from an explicitly configured BGP
peer.

- A denial of service vulnerability can be triggered by a
malformed COMMUNITY attribute from an explicitly
configured BGP peer, when the daemon has debugging
enabled.

See also :

http://www.quagga.net/download/attic/quagga-0.99.9.changelog.txt

Solution :

Upgrade to version 0.99.9 or later.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:N/A:P)
CVSS Temporal Score : 2.9
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 59795 ()

Bugtraq ID: 25634

CVE ID: CVE-2007-4826