Quagga < 0.98.6 / 0.99.4 Multiple Vulnerabilities

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the installation of
Quagga listening on the remote host is affected by multiple
vulnerabilities :

- An information disclosure vulnerability in RIPD can be
triggered by a REQUEST packet, such as SEND UPDATE, on
hosts that disable RIPv1 or require plaintext or MD5
authentication. (CVE-2006-2223)

- An authentication bypass vulnerability in RIPD may allow
unauthenticated, remote attackers to modify routing
state via RIPv1 RESPONSE packets. (CVE-2006-2224)

- A denial of service vulnerability in Zebra can be
triggered by a certain BGP command. (CVE-2006-2276)

See also :

http://bugzilla.quagga.net/show_bug.cgi?id=261
http://bugzilla.quagga.net/show_bug.cgi?id=262
http://www.quagga.net/download/attic/quagga-0.99.4.changelog.txt
http://lists.quagga.net/pipermail/quagga-dev/2006-March/004052.html
http://archives.neohapsis.com/archives/fulldisclosure/2006-05/0029.html

Solution :

Upgrade to version 0.98.6 / 0.99.4 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 59793 ()

Bugtraq ID: 17808
17979

CVE ID: CVE-2006-2223
CVE-2006-2224
CVE-2006-2276