Quagga < 0.99.21 BGP Denial of Service Vulnerability

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by a denial of service
vulnerability.

Description :

According to its self-reported version number, the installation of
Quagga's BGP daemon listening on the remote host is affected by a
denial of service vulnerability. Unauthenticated attackers on the
local network can trigger this issue by leveraging a BGP peering
relationship and sending a malformed Outbound Route Filtering
capability TLV in an OPEN message.

See also :

http://savannah.nongnu.org/forum/forum.php?forum_id=7214
http://www.quagga.net/download/quagga-0.99.21.changelog.txt

Solution :

Upgrade to version 0.99.21 or later.

Risk factor :

Low / CVSS Base Score : 2.9
(CVSS2#AV:A/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 2.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 59792 ()

Bugtraq ID: 53775

CVE ID: CVE-2012-1820