Quagga < 0.99.20.1 Multiple Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the installation of
Quagga listening on the remote host is affected by multiple
vulnerabilities :

- A buffer overflow vulnerability exists in OSPFD can be
triggered by a specially-crafted Link Status Update
message that is smaller than the length specified in
its header, leading to denial of service.
(CVE-2012-0249)

- A buffer overflow vulnerability in exists OSPFD can be
triggered by a specially-crafted Link Status Update
message containing a network-LSA link-state
advertisement for which the data-structure length is
smaller than the value in the Length header field,
leading to denial of service. (CVE-2012-0250)

- A denial of service vulnerability exists in BGPD that
can be triggered by a specially-crafted OPEN message
with a malformed four-octet AS Number Capability.
(CVE-2012-0250)

See also :

https://bugzilla.quagga.net/show_bug.cgi?id=705
http://savannah.nongnu.org/forum/forum.php?forum_id=7151
http://www.quagga.net/download/quagga-0.99.20.1.changelog.txt

Solution :

Upgrade to version 0.99.20.1 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 59791 ()

Bugtraq ID: 52531

CVE ID: CVE-2012-0249
CVE-2012-0250
CVE-2012-0255