Quagga < 0.99.19 Multiple Vulnerabilities

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the installation of
Quagga listening on the remote host is affected by multiple
vulnerabilities :

- A denial of service vulnerability in OSPF6D can be
triggered by a specially-crafted Link Status Update
message with an invalid IPv6 prefix length.
(CVE-2011-3323)

- A denial of service vulnerability in OSPF6D can be
triggered by a specially-crafted IPv6 Database
Description message with trailing zero values in the
Link State Advertisement header list. (CVE-2011-3324)

- A denial of service vulnerability in OSPFD can be
triggered by a 0x0A type field in an IPv4 packet header
or a truncated IPv4 Hello packet. (CVE-2011-3325)

- A denial of service vulnerability in OSPFD can be
triggered by a specially-crafted IPv4 Link State Update
message with an invalid Link State Advertisement type.
(CVE-2011-3326)

- A heap-based buffer overflow in BGPD can be triggered by
a specially-crafted UPDATE message over IPv4.
(CVE-2011-3326)

See also :

http://savannah.nongnu.org/forum/forum.php?forum_id=7143
http://www.quagga.net/download/quagga-0.99.19.changelog.txt

Solution :

Upgrade to version 0.99.19 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 59790 ()

Bugtraq ID: 49784

CVE ID: CVE-2011-3323
CVE-2011-3324
CVE-2011-3325
CVE-2011-3326
CVE-2011-3327