Quagga < 0.99.12 BGPD Denial of Service Vulnerability

This script is Copyright (C) 2012 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by a denial of service
vulnerability.

Description :

According to its self-reported version number, the installation of
Quagga's BGP daemon listening on the remote host is affected by a
denial of service vulnerability. The issue can be triggered via an AS
path containing ASN elements whose string representation is longer
than expected.

See also :

http://www.quagga.net/download/attic/quagga-0.99.12.changelog.txt
http://thread.gmane.org/gmane.network.quagga.devel/6513

Solution :

Upgrade to version 0.99.12 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 59787 ()

Bugtraq ID: 34817

CVE ID: CVE-2009-1572