GLSA-201206-29 : mount-cifs: Multiple vulnerabilites

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-201206-29
(mount-cifs: Multiple vulnerabilites)

Multiple vulnerabilities have been discovered in mount-cifs. Please
review the CVE identifiers referenced below for details.

Impact :

The vulnerabilities allow local users to cause a denial of service (mtab
corruption) via a crafted string. Also, local users could mount a CIFS
share on an arbitrary mountpoint, and gain privileges via a symlink
attack on the mountpoint directory file.

Workaround :

There is no known workaround at this time.

See also :

Solution :

Gentoo has discontinued support for mount-cifs. We recommend that users
unmerge mount-cifs:
# emerge --unmerge 'net-fs/mount-cifs'

Risk factor :

Medium / CVSS Base Score : 4.4
CVSS Temporal Score : 3.6
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 59702 ()

Bugtraq ID: 37992

CVE ID: CVE-2010-0547