GLSA-201206-06 : OpenJPEG: User-assisted execution of arbitrary code

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201206-06
(OpenJPEG: User-assisted execution of arbitrary code)

An error in jp2.c of OpenJPEG could allow an out-of-bounds write error.

Impact :

A remote attacker could entice a user to open a specially crafted JPEG
file, possibly resulting in execution of arbitrary code or a Denial of
Service condition.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201206-06.xml

Solution :

All OpenJPEG users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-libs/openjpeg-1.5.0'

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 59634 ()

Bugtraq ID: 52654

CVE ID: CVE-2012-1499