GLSA-201204-06 : PolicyKit: Multiple vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201204-06
(PolicyKit: Multiple vulnerabilities)

Multiple vulnerabilities have been found in PolicyKit:
Error messages in the pkexec utility disclose the existence of local
files (CVE-2010-0750).
The pkexec utility initially checks the effective user ID of its
parent process for authorization, instead of checking the real user ID
(CVE-2011-1485).
Members of the 'wheel' group are able to execute commands as an
administrator without a password (CVE-2011-4945).

Impact :

A local attacker could gain elevated privileges or sensitive
information.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201204-06.xml

Solution :

All PolicyKit users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=sys-auth/polkit-0.104-r1'

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 59622 ()

Bugtraq ID: 39198
47496

CVE ID: CVE-2010-0750
CVE-2011-1485
CVE-2011-4945