iTunes < 10.6.3 m3u Multiple Buffer Overflow Vulnerabilities (Mac OS X)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote host contains a multimedia application that has multiple
buffer overflow vulnerabilities.

Description :

The version of iTunes installed on the remote Mac OS X host is
earlier than 10.6.3 and is, therefore, affected by stack and heap
based buffer overflow vulnerabilities. The application does not
properly handle 'm3u' playlist files. This error can cause the
application to crash or possibly allow arbitrary code execution.

See also :

http://support.apple.com/kb/HT5318
http://lists.apple.com/archives/security-announce/2012/Jun/msg00000.html

Solution :

Upgrade to iTunes 10.6.3 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 59499 ()

Bugtraq ID: 53933
54113

CVE ID: CVE-2012-0677