MySQL 5.5 < 5.5.24 Security Bypass Vulnerability

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by a security bypass vulnerability.

Description :

The version of MySQL 5.5 installed on the remote host is earlier than
5.5.24 and is, therefore, affected by the following vulnerabilities :

- Several errors exist related to 'GIS Extension',
'Server', 'InnoDB' and 'Server Optimizer' components
that can allow denial of service attacks.
(CVE-2012-0540, CVE-2012-1734, CVE-2012-1735,
CVE-2012-1756, CVE-2012-1757)

- A security bypass vulnerability exists that occurs due
to improper casting during user login sessions.
(Bug #64884 / CVE-2012-2122)

- An error exists related to key length and sort order
index that can lead to application crashes.
(Bug #59387 / CVE-2012-2749)

See also :

http://seclists.org/oss-sec/2012/q2/493
http://dev.mysql.com/doc/refman/5.5/en/news-5-5-24.html
http://www.nessus.org/u?4a857db8

Solution :

Upgrade to MySQL version 5.5.24 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C)
CVSS Temporal Score : 5.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true