MySQL 5.1 < 5.1.63 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL 5.1 installed on the remote host is earlier than
5.1.63 and is, therefore, affected by multiple vulnerabilities :

- Several errors exist related to 'GIS Extension' and
'Server Optimizer' components that can allow denial of
service attacks. (CVE-2012-0540, CVE-2012-1689,
CVE-2012-1734)

- A security bypass vulnerability exists that occurs due
to improper casting during user login sessions.
(Bug #64884 / CVE-2012-2122)

- An error exists related to key length and sort order
index that can lead to application crashes.
(Bug #59387 / CVE-2012-2749)

See also :

http://seclists.org/oss-sec/2012/q2/493
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-63.html
http://www.nessus.org/u?4a857db8

Solution :

Upgrade to MySQL version 5.1.63 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 59448 ()

Bugtraq ID: 53911
54540
54551
54547
55120

CVE ID: CVE-2012-0540
CVE-2012-1689
CVE-2012-1734
CVE-2012-2122
CVE-2012-2749