Mac OS X : Safari < 5.1.7 Multiple Vulnerabilities

This script is Copyright (C) 2012-2013 Tenable Network Security, Inc.


Synopsis :

The remote host contains a web browser that is affected by several
vulnerabilities.

Description :

The version of Safari installed on the remote Mac OS X host is
earlier than 5.1.7. It is, therefore, potentially affected by several
issues :

- Two unspecified errors exist that can allow malicious
sites to perform cross-site scripting attacks.
(CVE-2011-3046, CVE-2011-3056)

- An unspecified memory corruption error exists that can
allow malicious sites to crash the application or
potentially execute arbitrary code. (CVE-2012-0672)

- A state-tracking issue exists that can allow malicious
sites to populate HTML form values of other sites with
arbitrary data. (CVE-2012-0676)

See also :

http://support.apple.com/kb/HT5282
http://lists.apple.com/archives/security-announce/2012/May/msg00002.html

Solution :

Upgrade to Safari 5.1.7 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 59068 ()

Bugtraq ID: 52369
53404
53407
53446

CVE ID: CVE-2011-3046
CVE-2011-3056
CVE-2012-0672
CVE-2012-0676