Asterisk Manager User Unauthorized Shell Access (AST-2012-004)

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The version of Asterisk installed on the remote host may be affected
by a privilege escalation vulnerability.

Description :

According to the version in its SIP banner, the version of Asterisk
running on the remote host is potentially affected by a vulnerability
that could allow an authenticated, remote attacker to run arbitrary
commands with the credentials of the Asterisk server.

See also :

http://downloads.asterisk.org/pub/security/AST-2012-004.html
https://issues.asterisk.org/jira/browse/ASTERISK-17465

Solution :

Upgrade to Asterisk 1.6.2.24 / 1.8.11.1 / 10.3.1 / C.3.7.4 or apply
the patches listed in the Asterisk advisory.

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 58904 ()

Bugtraq ID: 53206

CVE ID: CVE-2012-2414