MySQL 5.1 < 5.1.62 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL 5.1 installed on the remote host is earlier
than 5.1.62. It is, therefore, affected by the following
vulnerabilities :

- An error exists related to the included yaSSL
component that could allow arbitrary code execution.

- Errors exist related to 'Server Optimizer',
'Server DML', 'Partition' and, in combination with
InnoDB, 'HANDLER READ NEXT' that could allow denial of
service attacks. (CVE-2012-1688, CVE-2012-1690,
CVE-2012-1703, CVE-2012-2102)

See also :

Solution :

Upgrade to MySQL version 5.1.62 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
CVSS Temporal Score : 5.9
Public Exploit Available : true

Family: Databases

Nessus Plugin ID: 58802 ()

Bugtraq ID: 51925

CVE ID: CVE-2012-0882

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial