OpenSSL 1.0.1 < 1.0.1a ASN.1 asn1_d2i_read_bio Memory Corruption

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote host may be affected by a memory corruption vulnerability.

Description :

According to its banner, the remote web server is running a version
of OpenSSL 1.0.1 earlier than 1.0.1a. As such, the OpenSSL library
itself is reportedly affected by a memory corruption vulnerability via
an integer truncation error in the function 'asn1_d2i_read_bio' when
reading ASN.1 DER format data.

Applications using the 'BIO' or 'FILE' based functions (i.e.,
'd2i_*_bio' or 'd2i_*_fp' functions) are affected by this issue. Also
affected are 'S/MIME' or 'CMS' applications using 'SMIME_read_PKCS7'
or 'SMIME_read_CMS' parsers. The OpenSSL command line utility is
affected if used to handle untrusted DER formatted data.

Note that the SSL/TLS code of OpenSSL is not affected. Also not
affected are applications using memory-based ASN.1 functions (e.g.,
'd2i_X509', 'd2i_PKCS12', etc.) nor are applications using only PEM
functions.

See also :

http://openssl.org/news/secadv_20120419.txt
http://www.openssl.org/news/changelog.html
http://seclists.org/fulldisclosure/2012/Apr/210

Solution :

Upgrade to OpenSSL 1.0.1a or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 58801 ()

Bugtraq ID: 53158

CVE ID: CVE-2012-2110