RealNetworks Helix Server 14.x < 14.3.x Multiple Vulnerabilities

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The remote media streaming server is affected by multiple

Description :

According to its banner, the remote host is running version 14.x of
RealNetworks Helix Server / Helix Mobile Server. Such versions are
potentially affected by multiple vulnerabilities :

- Administrative and user credentials are insecurely
stored in a flat file database. This file may be
accessed by local users to disclose passwords stored in
plaintext. (CVE-2012-1923)

- A buffer overflow exists in the code that parses
authentication credentials. It may be possible for a
remote attacker to exploit this issue and execute
arbitrary code. (CVE-2012-0942)

- Multiple unspecified cross-site scripting
vulnerabilities. (CVE-2012-1984)

- A specially crafted malformed URL can cause the server
process to crash if opened by an administrator.

- Establishing and immediately closing a TCP connection on
port 705 can cause the SNMP Master Agent to crash.

- A specially crafted Open-PDU request sent to the SNMP
Master Agent can cause it to crash due to an unhandled
exception. (CVE-2012-2268)

See also :

Solution :

Upgrade to RealNetworks Helix Server / Helix Mobile Server 14.3.x or

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 7.4
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 58724 ()

Bugtraq ID: 52929

CVE ID: CVE-2012-0942