Adobe Reader < 10.1.3 / 9.5.1 Multiple Vulnerabilities (APSB12-03, APSB12-05, APSB12-07, APSB12-08) (Mac OS X)

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.


Synopsis :

The version of Adobe Reader on the remote Mac OS X host is affected by
multiple vulnerabilities.

Description :

The version of Adobe Reader installed on the remote Mac OS X host is
prior to 10.1.3 or 9.5.1. It is, therefore, affected by the following
vulnerabilities :

- An integer overflow condition exists that allows an
attacker to execute arbitrary code via a crafted True
Type Font (TFF). (CVE-2012-0774)

- A memory corruption issue exists in JavaScript handling
that allows an attacker to execute arbitrary code.
(CVE-2012-0775)

- A security bypass vulnerability exists in the Adobe
Reader installer that allows an attacker to execute
arbitrary code. (CVE-2012-0776)

- A memory corruption issue exists in the JavaScript API
that allows an attacker to execute arbitrary code or
cause a denial of service. (CVE-2012-0777)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://dvlabs.tippingpoint.com/advisory/TPTI-12-03
http://www.adobe.com/support/security/bulletins/apsb12-03.html
http://www.adobe.com/support/security/bulletins/apsb12-05.html
http://www.adobe.com/support/security/bulletins/apsb12-07.html
http://www.adobe.com/support/security/bulletins/apsb12-08.html

Solution :

Upgrade to Adobe Reader version 10.1.3 / 9.5.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:H/RL:OF/RC:ND)
Public Exploit Available : true