MySQL 5.5 < 5.5.22 Multiple Vulnerabilities

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL 5.5 installed on the remote host is earlier than
5.5.22. It is, therefore, affected by the following vulnerabilities :

- An error exists related to the included yaSSL
component that could allow arbitrary code execution.
(CVE-2012-0882)

- Errors exist related to 'Server Optimizer',
'Server DML', 'Partition' and, in combination with
InnoDB, 'HANDLER READ NEXT' that could allow denial of
service attacks. (CVE-2012-1688, CVE-2012-1690,
CVE-2012-1697, CVE-2012-1703, CVE-2012-2102)

See also :

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-22.html
http://www.nessus.org/u?113e249d
http://www.openwall.com/lists/oss-security/2012/02/24/2

Solution :

Upgrade to MySQL version 5.5.22 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true