GLSA-201203-13 : Openswan: Denial of Service

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The remote Gentoo host is missing one or more security-related

Description :

The remote host is affected by the vulnerability described in GLSA-201203-13
(Openswan: Denial of Service)

Two vulnerabilities have been found in Openswan:
Improper permissions are used on /var/run/ and
/var/lock/subsys/ipsec (CVE-2011-2147).
Openswan contains a use-after-free error in the cryptographic helper
handler (CVE-2011-4073).

Impact :

A remote authenticated attacker or a local attacker may be able to cause
a Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

Solution :

All Openswan users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/openswan-2.6.37'
NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since November 10, 2011. It is likely that your system is
already no longer affected by this issue.

Risk factor :

Medium / CVSS Base Score : 4.0
CVSS Temporal Score : 3.3
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 58378 ()

Bugtraq ID: 47958

CVE ID: CVE-2011-2147