iTunes < 10.6 Multiple Vulnerabilities (uncredentialed check)

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote host contains a multimedia application that has multiple
vulnerabilities.

Description :

The remote version of iTunes is older than 10.6. Thus, it is
reportedly affected by numerous memory corruption vulnerabilities in
its WebKit component.

Note that these issues only affect iTunes on Windows.

See also :

http://www.zerodayinitiative.com/advisories/ZDI-12-147/
http://archives.neohapsis.com/archives/fulldisclosure/2012-08/0267.html
http://support.apple.com/kb/HT5191
http://lists.apple.com/archives/security-announce/2012/Mar/msg00000.html

Solution :

Upgrade to iTunes 10.6 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false