GLSA-201203-10 : libmikmod: User-assisted execution of arbitrary code

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201203-10
(libmikmod: User-assisted execution of arbitrary code)

Multiple boundary errors have been found in load_it.c in libmikmod,
which may cause a buffer overflow.

Impact :

A remote attacker could entice a user to open specially crafted files in
an application linked against libmikmod, possibly resulting in execution
of arbitrary code with the permissions of the user running the
application, or Denial of Service.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201203-10.xml

Solution :

All libmikmod 3.2 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose
'>=media-libs/libmikmod-3.2.0_beta2-r3'
All libmikmod 3.1 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-libs/libmikmod-3.1.12-r1'
Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 58220 ()

Bugtraq ID: 41917
42464

CVE ID: CVE-2010-2546
CVE-2010-2971