Flash Player for Mac <= 10.3.183.15 / 11.1.102.62 Multiple Vulnerabilities (APSB12-05)

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on
the remote Mac OS X host is 10.x equal to or earlier than 10.3.183.15
or 11.x equal to or earlier than 11.1.102.62. It is, therefore,
reportedly affected by several critical vulnerabilities :

- A memory corruption vulnerability exists in Matrix3D
that could lead to code execution. (CVE-2012-0768)

- Multiple integer errors exist that could lead to
information disclosure. (CVE-2012-0769)

See also :

http://www.adobe.com/support/security/bulletins/apsb12-05.html

Solution :

Upgrade to Adobe Flash version 10.3.183.16 / 11.1.102.63 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 58208 ()

Bugtraq ID: 52297
52299

CVE ID: CVE-2012-0768
CVE-2012-0769