GLSA-201202-06 : Asterisk: Denial of Service

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201202-06
(Asterisk: Denial of Service)

A vulnerability has been found in Asterisk's handling of certain
encrypted streams where the res_srtp module has been loaded but video
support has not been enabled.

Impact :

A remote attacker could send a specially crafted SDP message to the
Asterisk daemon, possibly resulting in a Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201202-06.xml

Solution :

All Asterisk users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-misc/asterisk-1.8.8.2'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.2
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 58102 ()

Bugtraq ID: 51581

CVE ID: CVE-2012-0885