OpenSSL 0.9.8s DTLS Denial of Service

This script is Copyright (C) 2012-2014 Tenable Network Security, Inc.


Synopsis :

The remote host may be affected by a denial of service
vulnerability.

Description :

According to its banner, the remote web server uses OpenSSL version
0.9.8s. This version has a flaw in the fix for CVE-2011-4108 such
that Datagram Transport Layer Security (DTLS) applications that use it
are vulnerable to a denial of service attack.

See also :

http://www.openssl.org/news/secadv_20120118.txt
http://www.openssl.org/news/changelog.html

Solution :

Upgrade to OpenSSL 0.9.8t or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 57711 ()

Bugtraq ID: 51563

CVE ID: CVE-2012-0050