Cacti < 0.8.7g Multiple XSS and HTML Injection Vulnerabilities

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.


Synopsis :

The remote web server is running a PHP application that is affected by
multiple cross-site scripting and HTML injection vulnerabilities.

Description :

According to its self-reported version number, the Cacti application
running on the remote web server is prior to version 0.8.7g. It is,
therefore, potentially affected by multiple cross-site scripting and
HTML injection vulnerabilities. An attacker may be able to exploit
these issues to inject arbitrary HTML or script code into a user's
browser to be executed within the security context of the affected
site.

See also :

http://cacti.net/release_notes_0_8_7g.php
http://marc.info/?l=oss-security&m=127978954522586

Solution :

Upgrade to Cacti 0.8.7g or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 57617 ()

Bugtraq ID: 42575

CVE ID: CVE-2010-2544
CVE-2010-2545