Apache Tomcat 7.x < 7.0.23 Hash Collision Denial of Service

This script is Copyright (C) 2012-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server is potentially affected by a denial of service

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.x listening on the remote host is earlier than 7.0.23 and is
therefore potentially affected by a denial of service vulnerability.

Large numbers of crafted form parameters can cause excessive CPU
consumption due to hash collisions.

Note that Nessus did not actually test for the flaw but instead has
relied on the version in Tomcat's banner or error page.

See also :


Solution :

Upgrade to Apache Tomcat version 7.0.23 or later.

Alternatively, as a workaround, set the 'maxPostSize' configuration
variable to the lowest sensible value required to support your hosted

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 57541 ()

Bugtraq ID: 51200

CVE ID: CVE-2011-4858