lighttpd < 1.4.30 base64_decode Function Out-of-Bounds Read Error DoS

This script is Copyright (C) 2011-2016 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by a denial of service

Description :

According to its banner, the version of lighttpd running on the remote
host is prior to 1.4.30. It is, therefore, affected by a denial of
service vulnerability. The HTTP server allows out-of-bounds values to
be decoded during the auth process and later uses these values as
offsets. Using negative values as offsets can result in application

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

See also :

Solution :

Upgrade to lighttpd version 1.4.30 or later. Alternatively, apply the
vendor-supplied patch or disable mod_auth.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 3.9
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 57410 ()

Bugtraq ID: 50851

CVE ID: CVE-2011-4362

Ready to Scan Unlimited IPs & Run Compliance Checks?

Upgrade to Nessus Professional today!

Buy Now

Combine the Power of Nessus with the Ease of Cloud

Start your free Nessus Cloud trial now!

Begin Free Trial