lighttpd < 1.4.30 base64_decode Function Out-of-Bounds Read Error DoS

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is potentially affected by a denial of service
vulnerability.

Description :

According to its banner, the version of lighttpd installed on the
remote host is older than 1.4.30 and is potentially affected by a
denial of service vulnerability.

The HTTP server allows out-of-bounds values to be decoded during the
auth process and later uses these values as offsets. Using negative
values as offsets can result in application crashes.

See also :

http://www.nessus.org/u?5fc05344
http://redmine.lighttpd.net/issues/2370
http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2011_01.txt

Solution :

Either upgrade to lighttpd version 1.4.30 or later, apply the vendor's
patch, or disable mod_auth if you do not need it.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 57410 ()

Bugtraq ID: 50851

CVE ID: CVE-2011-4362