Firefox 3.6 < 3.6.25 Jar File Enter Key Dialog Bypass (Mac OS X)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser that is potentially
affected by a security bypass vulnerability.

Description :

The installed version of Firefox 3.6 is earlier than 3.6.25. Such
versions are potentially affected by a security bypass vulnerability.

The fix for MFSA-2011-40 was incomplete regarding Java Jar files. The
files were intended to be treated as executables as part of the fix,
but they are not treated as such.

See also :

http://www.mozilla.org/security/announce/2011/mfsa2011-59.html

Solution :

Upgrade to Firefox 3.6.25 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 57358 ()

Bugtraq ID: 51139

CVE ID: CVE-2011-3666