Apache Tomcat 7.x < 7.0.22 Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is potentially affected by multiple
vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.x listening on the remote host is earlier than 7.0.22 and is,
therefore, potentially affected by multiple vulnerabilities:

- An information disclosure vulnerability exists. Request
information is cached in two objects and these objects
are not recycled at the same time. Further requests can
obtain sensitive information if certain error conditions
occur. (CVE-2011-3375)

- The web server is not properly restricting access to
the servlets that provide the functionality of the
Manager application. This can allow untrusted web
applications to access privileged internal functionality
such as gathering information on running web
applications and deploying additional web applications.
(CVE-2011-3376)

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page.

See also :

http://svn.apache.org/viewvc?view=revision&revision=1176588
http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.22

Solution :

Upgrade to Apache Tomcat version 7.0.22 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 57082 ()

Bugtraq ID: 50603
51442

CVE ID: CVE-2011-3375
CVE-2011-3376