GLSA-201111-03 : OpenTTD: Multiple vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201111-03
(OpenTTD: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in OpenTTD. Please review
the CVE identifiers referenced below for details.

Impact :

A remote attacker could execute arbitrary code with the privileges of
the OpenTTD process or cause a Denial of Service. Local users could cause
a Denial of Service.

Workaround :

There is no known workaround at this time.

See also :

http://www.gentoo.org/security/en/glsa/glsa-201111-03.xml

Solution :

All OpenTTD users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=games-simulation/openttd-1.1.3'
NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since September 27, 2011. It is likely that your system is
already no longer affected by this issue.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 56807 ()

Bugtraq ID: 44844
49439

CVE ID: CVE-2010-4168
CVE-2011-3341
CVE-2011-3342
CVE-2011-3343