Ubuntu 10.04 LTS / 10.10 / 11.04 / 11.10 : libmodplug vulnerabilities (USN-1255-1)

Ubuntu Security Notice (C) 2011-2013 Canonical, Inc. / NASL script (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

Hossein Lotfi discovered that libmodplug did not correctly handle
certain malformed media files. If a user or automated system were
tricked into opening a crafted media file, an attacker could cause a
denial of service or possibly execute arbitrary code with privileges
of the user invoking the program. (CVE-2011-2911, CVE-2011-2912,
CVE-2011-2913)

It was discovered that libmodplug did not correctly handle certain
malformed media files. If a user or automated system were tricked into
opening a crafted media file, an attacker could cause a denial of
service or possibly execute arbitrary code with privileges of the user
invoking the program. (CVE-2011-2914, CVE-2011-2915).

Solution :

Update the affected libmodplug0c2 and / or libmodplug1 packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 56767 ()

Bugtraq ID: 48979

CVE ID: CVE-2011-2911
CVE-2011-2912
CVE-2011-2913
CVE-2011-2914
CVE-2011-2915