IBM WebSphere Application Server < 6.1.0.29 Multiple Vulnerabilities

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote application server is affected by multiple vulnerabilities.

Description :

IBM WebSphere Application Server 6.1 before Fix Pack 29 appears to be
running on the remote host. As such, it is reportedly affected by
multiple vulnerabilities :

- A cross-site request forgery vulnerability exists due
to insufficient validation of user-supplied input by
the administrative console. (PK87176)

- Due to an error in Java Naming and Directory Interface,
it may be possible to obtain sensitive information.
(PK91414)

- The administrative console is affected by a
cross-site scripting vulnerability. (PK92057)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21404665
http://www-01.ibm.com/support/docview.wss?uid=swg27009778
http://www-01.ibm.com/support/docview.wss?uid=swg27007951#61029

Solution :

If using WebSphere Application Server, apply Fix Pack 29 (6.1.0.29) or
later.

Otherwise, if using embedded WebSphere Application Server packaged with
Tivoli Directory Server, apply the latest recommended eWAS fix pack.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 56683 ()

Bugtraq ID: 37015
37355

CVE ID: CVE-2009-2746
CVE-2009-2747
CVE-2009-2748