phpMyAdmin 3.4.x < 3.4.6 Cross-Site Scripting (PMASA-2011-16)

This script is Copyright (C) 2011 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a PHP application that is affected by
a cross-site scripting vulnerability.

Description :

The version of phpMyAdmin hosted on the remote server is 3.4.x prior
to 3.4.6 and is affected by a cross-site scripting vulnerability. The
'Servers-0-verbose' parameter is not properly sanitized by methods in
'libraries/config/ConfigFile.class.php' as called by the script
'setup/index.php'. Persistent cross-site scripting is possible if
improper filesystem permissions are in place.

See also :

http://www.nessus.org/u?45ba6757
http://www.phpmyadmin.net/home_page/security/PMASA-2011-16.php

Solution :

Apply the vendor patches or upgrade to phpMyAdmin version 3.4.6 or
later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 56652 ()

Bugtraq ID: 50175

CVE ID: CVE-2011-4064