Apache Tomcat 5.5.x < 5.5.34 Multiple Vulnerabilities

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 5.5.x listening on the remote host is earlier than 5.5.34 and
is affected by multiple vulnerabilities:

- Several weaknesses were found in the HTTP Digest
authentication implementation. The issues are as
follows: replay attacks are possible, server nonces
are not checked, client nonce counts are not checked,
'quality of protection' (qop) values are not checked,
realm values are not checked and the server secret is
a hard-coded, known string. The effect of these issues
is that Digest authentication is no stronger than Basic
authentication. (CVE-2011-1184, CVE-2011-5062,
CVE-2011-5063, CVE-2011-5064)

- An error handling issue exists related to the
MemoryUserDatabase that allows user passwords to be
disclosed through log files. (CVE-2011-2204)

- An input validation error exists that allows a local
attacker to either bypass security or carry out denial
of service attacks when the APR or NIO connectors are
enabled. (CVE-2011-2526)

- A component that Apache Tomcat relies on called 'jsvc'
contains an error in that it does not drop capabilities
after starting and can allow access to sensitive files
owned by the super user. Note this vulnerability only
affects Linux operating systems and only when 'jsvc' is
compiled with libpcap and the '-user' parameter is
used. (CVE-2011-2729)

- Specially crafted requests are incorrectly processed by
Tomcat and can cause the server to allow injection of
arbitrary AJP messages. This can lead to authentication
bypass and disclosure of sensitive information. Note
this vulnerability only occurs when the
org.apache.jk.server.JkCoyoteHandler AJP connector is
not used, POST requests are accepted, and the request
body is not processed.(CVE-2011-3190)

Note that Nessus did not actually test for the flaws but instead has
relied on the version in Tomcat's banner or error page.

See also :

http://tomcat.apache.org/security-5.html#Fixed_in_Apache_Tomcat_5.5.34

Solution :

Upgrade to Apache Tomcat version 5.5.34 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true