Flash Player for Mac <= 10.3.183.7 Multiple Vulnerabilities (APSB11-26)

This script is Copyright (C) 2011-2012 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on
the remote Mac OS X host is 10.3.183.7 or earlier. It is therefore
reportedly affected by several critical vulnerabilities :

- Multiple AVM stack overflow vulnerabilities could lead
to code execution. (CVE-2011-2426, CVE-2011-2427)

- A logic error issue could lead to code execution or
a browser crash. (CVE-2011-2428)

- A Flash Player security control bypass vulnerability
could lead to information disclosure. (CVE-2011-2429)

- A streaming media logic error vulnerability could lead
to code execution. (CVE-2011-2430)

- A universal cross-site scripting vulnerability could be
abused to take actions on a user's behalf on any
website if the user is tricked into visiting a
malicious website. Note that this issue is reportedly
being actively exploited in targeted attacks.
(CVE-2011-2444)

See also :

http://www.nessus.org/u?ace6f27f
http://www.adobe.com/support/security/bulletins/apsb11-26.html

Solution :

Upgrade to Adobe Flash for Mac version 10.3.183.10 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 56258 ()

Bugtraq ID: 49710
49714
49715
49716
49717
49718

CVE ID: CVE-2011-2426
CVE-2011-2427
CVE-2011-2428
CVE-2011-2429
CVE-2011-2430
CVE-2011-2444