Apache 2.2 < 2.2.21 mod_proxy_ajp DoS

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote web server may be affected by a denial
of service vulnerability.

Description :

According to its banner, the version of Apache 2.2 installed on the
remote host is earlier than 2.2.21. It therefore is potentially
affected by a denial of service vulnerability.

An error exists in the 'mod_proxy_ajp' module that can allow
specially crafted HTTP requests to cause a backend server to
temporarily enter an error state. This vulnerability only occurs
when 'mod_proxy_ajp' is used along with 'mod_proxy_balancer'.

Note that Nessus did not actually test for the flaws but instead has
relied on the version in the server's banner.

See also :

http://www.nessus.org/u?34a2f1d8
http://httpd.apache.org/security/vulnerabilities_22.html

Solution :

Upgrade to Apache version 2.2.21 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 56216 ()

Bugtraq ID: 49616

CVE ID: CVE-2011-3348