Apache Tomcat 7.x < 7.0.21 Arbitrary AJP Message Control

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote web server may allow authentication bypass and information
disclosure.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.x listening on the remote host is earlier than 7.0.21 and
therefore potentially allows an attacker to have control over AJP
messages.

Specially crafted requests are incorrectly processed by Tomcat and can
cause the server to allow injection of arbitrary AJP messages. This
can lead to authentication bypass and disclosure of sensitive
information.

Note this vulnerability only occurs when the following are true :

- the org.apache.jk.server.JkCoyoteHandler AJP connector
is not used.

- POST requests are accepted.

- the request body is not processed.

Also note that Nessus did not actually test for the flaw but instead
has relied on the version in Tomcat's banner or error page.

See also :

https://issues.apache.org/bugzilla/show_bug.cgi?id=51698
http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.21

Solution :

Upgrade to Apache Tomcat version 7.0.21 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 56070 ()

Bugtraq ID: 49353

CVE ID: CVE-2011-3190