CUPS < 1.4.7 'gif_read_lzw' Buffer Overflow

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote print service is affected by a buffer overflow
vulnerability.

Description :

According to its banner, the version of CUPS installed on the remote
host is earlier than 1.4.7.

There is a boundary error in the function 'gif_read_lzw' in the file
'filter/image-gif.c' that can allow an attacker to cause a heap-based
buffer overflow via specially crafted gif images.

See also :

http://www.cups.org/articles.php?L628
http://cups.org/str.php?L3867

Solution :

Upgrade to CUPS version 1.4.7 or later.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 3.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 56007 ()

Bugtraq ID: 49148

CVE ID: CVE-2011-2896