RHEL 4 / 5 : system-config-printer (RHSA-2011:1196)

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote Red Hat host is missing one or more security updates.

Description :

Updated system-config-printer packages that fix one security issue are
now available for Red Hat Enterprise Linux 4 and 5.

The Red Hat Security Response Team has rated this update as having
moderate security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from
the CVE link in the References section.

system-config-printer is a print queue configuration tool with a
graphical user interface.

It was found that system-config-printer did not properly sanitize
NetBIOS and workgroup names when searching for network printers. A
remote attacker could use this flaw to execute arbitrary code with the
privileges of the user running system-config-printer. (CVE-2011-2899)

All users of system-config-printer are advised to upgrade to these
updated packages, which contain a backported patch to resolve this
issue. Running instances of system-config-printer must be restarted
for this update to take effect.

See also :

https://www.redhat.com/security/data/cve/CVE-2011-2899.html
http://rhn.redhat.com/errata/RHSA-2011-1196.html

Solution :

Update the affected system-config-printer, system-config-printer-gui
and / or system-config-printer-libs packages.

Risk factor :

Medium / CVSS Base Score : 5.1
(CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P)

Family: Red Hat Local Security Checks

Nessus Plugin ID: 55965 ()

Bugtraq ID:

CVE ID: CVE-2011-2899