Adobe Flash Media Server < 3.5.7 / 4.0.3 Denial of Service (APSB11-20)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote media server is affected by a denial of service
vulnerability.

Description :

The version of Adobe Flash Media Server running on the remote host is
earlier than versions 3.5.7 / 4.0.3. As such, it is potentially
affected by a memory corruption issue that could lead to a denial of
service.

See also :

http://archives.neohapsis.com/archives/fulldisclosure/2011-10/0532.html
http://www.adobe.com/support/security/bulletins/apsb11-20.html

Solution :

Upgrade to Flash Media Server 3.5.7 / 4.0.3 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.4
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 55811 ()

Bugtraq ID: 49103

CVE ID: CVE-2011-2132