Flash Player for Mac <= 10.3.181.36 Multiple Vulnerabilities (APSB11-21)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on
the remote Mac OS X host is 10.3.181.36 or earlier. As such, it is
reportedly affected by several critical vulnerabilities :

- Multiple buffer overflow vulnerabilities could lead to
code execution. (CVE-2011-2130, CVE-2011-2134,
CVE-2011-2137, CVE-2011-2414, CVE-2011-2415)

- Multiple memory corruption vulnerabilities could lead to
code execution. (CVE-2011-2135, CVE-2011-2140,
CVE-2011-2417, CVE-2011-2424, CVE-2011-2425)

- Multiple integer overflow vulnerabilities could lead to
code execution. (CVE-2011-2136, CVE-2011-2138,
CVE-2011-2416)

- A cross-site information disclosure vulnerability
exists that could lead to code execution.
(CVE-2011-2139)

By tricking a user on the affected system into opening a specially
crafted document with Flash content, an attacker could leverage these
vulnerabilities to execute arbitrary code remotely on the system
subject to the user's privileges.

See also :

http://www.adobe.com/support/security/bulletins/apsb11-21.html

Solution :

Upgrade to Adobe Flash for Mac version 10.3.183.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true