MS11-069: Vulnerability in .NET Framework Could Allow Information Disclosure (2567951)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The Microsoft .NET Framework install on the remote host is affected by
an improper validation vulnerability.

Description :

The remote Windows host is running a version of the Microsoft .NET
Framework that improperly validates the trust level within the
System.Net.Sockets namespace. A remote attacker could exploit this
issue by tricking a user into viewing a specially crafted XML file,
resulting in information disclosure or partial denial of service.

See also :

http://technet.microsoft.com/en-us/security/bulletin/ms11-069

Solution :

Microsoft has released a set of patches for .NET Framework 2.0,
3.5.1, and 4.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P)
CVSS Temporal Score : 5.3
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 55799 ()

Bugtraq ID: 48991

CVE ID: CVE-2011-1978