LibreOffice < 3.3.3 / 3.4.0 LWP File Handling Overflow (Mac OS X)

This script is Copyright (C) 2012 Tenable Network Security, Inc.

Synopsis :

The remote Mac OS X host has a program affected by a buffer
overflow vulnerability.

Description :

The version of LibreOffice installed on the remote Mac OS X host is
earlier than 3.3.3 / 3.4.0. As such, it is reportedly affected by a
stack buffer overflow in the Lotus Word Pro import filter that arises
from its failure to properly handle object ids in '.lwp' documents.

If an attacker can trick a user on the affected system into importing
a specially crafted .lwp document into the application, he could
leverage this issue to execute arbitrary code subject to the user's

See also :

Solution :

Upgrade to LibreOffice 3.3.3 / 3.4.0 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 6.9
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 55576 ()

Bugtraq ID: 48387

CVE ID: CVE-2011-2685