MS11-044: Vulnerability in .NET Framework Could Allow Remote Code Execution (2538814)

This script is Copyright (C) 2011-2013 Tenable Network Security, Inc.


Synopsis :

The version of the .NET Framework installed on the remote host allows
arbitrary code execution.

Description :

The JIT compiler included with the version of the .NET Framework
installed on the remote host incorrectly validates certain values within
an object.

An attacker may be able to leverage this vulnerability to run arbitrary
code as the logged in user or the user account of ASP.NET on the
affected system under either of the following scenarios :

- Tricking a user on the affected host into viewing a
specially crafted web page using a web browser that can
run XAML Browser Applications (XBAPs).

- Uploading a malicious ASP.NET application to be hosted
on the affected host.

- Bypassing Code Access Security (CAS) restrictions in a
Windows .NET application.

See also :

http://technet.microsoft.com/en-us/security/bulletin/ms11-044

Solution :

Microsoft has released a set of patches for the .NET Framework on
Windows XP, 2003, Vista, 2008, 7, and 2008 R2.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows : Microsoft Bulletins

Nessus Plugin ID: 55124 ()

Bugtraq ID: 47834

CVE ID: CVE-2011-1271