Ubuntu 10.04 LTS / 10.10 / 11.04 : qemu-kvm vulnerabilities (USN-1145-1)

Ubuntu Security Notice (C) 2011-2014 Canonical, Inc. / NASL script (C) 2011-2014 Tenable Network Security, Inc.


Synopsis :

The remote Ubuntu host is missing one or more security-related patches.

Description :

It was discovered that QEMU did not properly perform validation of I/O
operations from the guest which could lead to heap corruption. An
attacker could exploit this to cause a denial of service of the guest
or possibly execute code with the privileges of the user invoking the
program. (CVE-2011-1750)

Nelson Elhage discoverd that QEMU did not properly handle memory when
removing ISA devices. An attacker could exploit this to cause a denial
of service of the guest or possibly execute code with the privileges
of the user invoking the program. (CVE-2011-1751)

When using QEMU with libvirt or virtualization management software
based on libvirt such as Eucalyptus and OpenStack, QEMU guests are
individually isolated by an AppArmor profile by default in Ubuntu.

Solution :

Update the affected qemu-kvm, qemu-kvm-extras and / or
qemu-kvm-extras-static packages.

Risk factor :

High / CVSS Base Score : 7.4
(CVSS2#AV:A/AC:M/Au:S/C:C/I:C/A:C)
CVSS Temporal Score : 6.4
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 55108 ()

Bugtraq ID: 47546

CVE ID: CVE-2011-1750
CVE-2011-1751