Ubuntu 9.10 / 10.04 LTS / 10.10 : pcsc-lite vulnerability (USN-1125-1)

Ubuntu Security Notice (C) 2011-2014 Canonical, Inc. / NASL script (C) 2011-2014 Tenable Network Security, Inc.

Synopsis :

The remote Ubuntu host is missing a security-related patch.

Description :

Rafael Dominguez Vega discovered that PCSC-Lite incorrectly handled
smart cards with malformed ATR messages. An attacker having physical
access could exploit this with a special smart card and cause a denial
of service or execute arbitrary code.

Solution :

Update the affected libpcsclite1 package.

Risk factor :

Medium / CVSS Base Score : 4.4
CVSS Temporal Score : 3.8
Public Exploit Available : false

Family: Ubuntu Local Security Checks

Nessus Plugin ID: 55085 ()

Bugtraq ID: 45450

CVE ID: CVE-2010-4531