Apache Tomcat 7.0.12 / 7.0.13 Security Constraint Bypass

This script is Copyright (C) 2011-2014 Tenable Network Security, Inc.

Synopsis :

The remote web server may be affected by a security constraint bypass

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.0.12 or 7.0.13 listening on the remote host may be affected
by a security constraint bypass vulnerability.

Fixes for CVE-2011-1088 and CVE-2011-1183 introduced an error in
'core/StandardWrapper.java' which allows an incorrect class loader to
be used. The effect of this is that security constraints configured
through annotations are ignored on the initial request to a servlet.
However, further requests are secured properly.

Note that Nessus did not actually test for the flaw but instead has
relied on the version in Tomcat's banner or error page.

See also :


Solution :

Upgrade to Apache Tomcat version 7.0.14 or later.

Risk factor :

Medium / CVSS Base Score : 5.1
CVSS Temporal Score : 3.8
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 54301 ()

Bugtraq ID: 47886

CVE ID: CVE-2011-1582